Skip to content
This repository has been archived by the owner on May 29, 2024. It is now read-only.

Update core logic to be less verbose & more simple in abstraction #357

Update core logic to be less verbose & more simple in abstraction

Update core logic to be less verbose & more simple in abstraction #357

Triggered via pull request November 5, 2023 12:45
Status Failure
Total duration 2m 36s
Artifacts

hygeine.yml

on: pull_request
Fit to window
Zoom out
Zoom in

Annotations

10 errors and 8 warnings
lint: internal/core/etl.go#L33
singleCaseSwitch: should rewrite switch statement to if statement (gocritic)
lint: internal/core/etl.go#L45
singleCaseSwitch: should rewrite switch statement to if statement (gocritic)
lint: internal/engine/manager.go#L100
captLocal: `PathID' should not be capitalized (gocritic)
lint: internal/engine/store.go#L54
captLocal: `PathID' should not be capitalized (gocritic)
lint: internal/engine/store.go#L62
captLocal: `PathID' should not be capitalized (gocritic)
lint: internal/etl/etl.go#L178
captLocal: `PathID' should not be capitalized (gocritic)
lint: internal/etl/etl.go#L215
captLocal: `PathID' should not be capitalized (gocritic)
lint: internal/etl/path.go#L37
captLocal: `PathID' should not be capitalized (gocritic)
lint: internal/etl/store.go#L98
captLocal: `PathIDs' should not be capitalized (gocritic)
lint: internal/subsystem/manager.go#L139
captLocal: `PathID' should not be capitalized (gocritic)
markdown-linting
The following actions uses node12 which is deprecated and will be forced to run on node16: actions/setup-node@v2. For more info: https://github.blog/changelog/2023-06-13-github-actions-all-actions-will-run-on-node16-instead-of-node12-by-default/
lint: internal/metrics/metrics.go#L214
unused-parameter: parameter 'h' seems to be unused, consider removing or renaming it as _ (revive)
lint: internal/metrics/metrics.go#L241
unused-parameter: parameter 'h' seems to be unused, consider removing or renaming it as _ (revive)
lint: internal/etl/registry/registry.go#L91
receiver-naming: receiver name cr should be consistent with previous receiver name r for Registry (revive)
lint: internal/etl/path.go#L93
receiver-naming: receiver name path should be consistent with previous receiver name p for path (revive)
lint: internal/etl/store.go#L18
exported: type name will be used as etl.EtlStore by other packages, and that stutters; consider calling this Store (revive)
lint: internal/app/init.go#L102
redefines-builtin-id: redefinition of the built-in function close (revive)
lint: e2e/etl_test.go#L5
unused-parameter: parameter 't' seems to be unused, consider removing or renaming it as _ (revive)