Skip to content

Commit

Permalink
remove clang module
Browse files Browse the repository at this point in the history
Relates to #8749

Signed-off-by: Konrad Weihmann <[email protected]>
  • Loading branch information
priv-kweihmann committed Apr 25, 2022
1 parent b4e06e2 commit be4cca8
Show file tree
Hide file tree
Showing 15 changed files with 0 additions and 284 deletions.
7 changes: 0 additions & 7 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -45,7 +45,6 @@ Support for these branches, including quality control, has to be done fully by t
- [Setup](#setup)
- [Kas](#kas)
- [Optional layer](#optional-layer)
- [meta-clang](#meta-clang)
- [meta-oe](#meta-oe)
- [meta-rubygems](#meta-rubygems)
- [Web monitor](#web-monitor)
Expand Down Expand Up @@ -114,10 +113,6 @@ Use `conf/kas/scatest-qemux86-64.yaml` from this layer

### Optional layer

#### meta-clang

To make the integration of clang (clang-tidy) work you need to add the [meta-clang](https://github.com/kraj/meta-clang) layer to your bblayer-file.

#### meta-oe

To enable the php/lua/npm support you need to add the [meta-oe](http://cgit.openembedded.org/meta-openembedded) layer to your bblayer-file.
Expand Down Expand Up @@ -186,7 +181,6 @@ The layer can check on a recipe-level or on an image-level.
| cbmc | C Bounded Model Checker | https://github.com/diffblue/cbmc/ | | x | | x | x | | | | | | | | | | | | | | | x | |
| checkbashisms | Shell script linter | https://manpages.debian.org/jessie/devscripts/checkbashisms.1.en.html | | | x | x | | | | x | | | | | | | | | | | | x | x |
| checksec | check on security issues | https://github.com/slimm609/checksec.sh | | | x | | | | | | | | | x | | | | | | | x | | |
| clang | C/C++ linter using LLVM | https://clang.llvm.org/extra/clang-tidy/ | meta-clang, manual enable | | | | x | x | x | | | | | | | | | | | | | | x |
| cmake | Get cmake errors and warnings | | | | | x | x | x | | | | | | | | | | | | | | x | |
| configcheck | Check application configurations | | | | x | | | | | | | | | | | | | | | x | | x | |
| cppcheck | C/C++ linter | https://github.com/danmar/cppcheck | | | | x | x | x | | | | | | | | | | | | | x | x | x |
Expand Down Expand Up @@ -294,7 +288,6 @@ each tool does have it's own benefits and flaws so don't be mad if you have 10k+
- [cbmc](docs/conf/module/cbmc.md)
- [checkbashism](docs/conf/module/checkbashism.md)
- [checksec](docs/conf/module/checksec.md)
- [clang](docs/conf/module/clang.md)
- [cmake](docs/conf/module/cmake.md)
- [configcheck](docs/conf/module/configcheck.md)
- [cppcheck](docs/conf/module/cppcheck.md)
Expand Down
1 change: 0 additions & 1 deletion classes/sca-blacklist.bbclass
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,6 @@ SCA_BLACKLIST_bandit ?= "linux-.*"
SCA_BLACKLIST_bitbake ?= ""
SCA_BLACKLIST_cbmc ?= "linux-.* busybox"
SCA_BLACKLIST_checksec ?= ""
SCA_BLACKLIST_clang ?= "linux-.*"
SCA_BLACKLIST_cmake ?= ""
SCA_BLACKLIST_configcheck ?= ""
SCA_BLACKLIST_cppcheck ?= "linux-.*"
Expand Down
139 changes: 0 additions & 139 deletions classes/sca-clang.bbclass

This file was deleted.

1 change: 0 additions & 1 deletion classes/sca-global.bbclass
Original file line number Diff line number Diff line change
Expand Up @@ -150,7 +150,6 @@ SCA_AVAILABLE_MODULES ?= "\
yara \
"
# additional layer requirements
SCA_AVAILABLE_MODULES[clang] = "clang-layer"
SCA_AVAILABLE_MODULES[cspell] = "openembedded-layer"
SCA_AVAILABLE_MODULES[eslint] = "openembedded-layer"
SCA_AVAILABLE_MODULES[htmlhint] = "openembedded-layer"
Expand Down
1 change: 0 additions & 1 deletion classes/sca-on-recipe.bbclass
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,6 @@ SCA_ENABLED_MODULES_RECIPE ?= "\
bitbake \
cbmc \
checkbashism \
clang \
cmake \
cppcheck \
cpplint \
Expand Down
2 changes: 0 additions & 2 deletions conf/layer.conf
Original file line number Diff line number Diff line change
Expand Up @@ -35,8 +35,6 @@ BBFILES += "\
BBFILES_DYNAMIC += "\
openembedded-layer:${LAYERDIR}/dynamic-layers/meta-oe/*.bb \
openembedded-layer:${LAYERDIR}/dynamic-layers/meta-oe/*.bbappend \
clang-layer:${LAYERDIR}/dynamic-layers/meta-clang/*.bb \
clang-layer:${LAYERDIR}/dynamic-layers/meta-clang/*.bbappend \
"

BBFILE_COLLECTIONS += "meta-sca"
Expand Down
64 changes: 0 additions & 64 deletions docs/conf/module/clang.md

This file was deleted.

1 change: 0 additions & 1 deletion dynamic-layers/meta-clang/clang_%.bbappend

This file was deleted.

1 change: 0 additions & 1 deletion files/module_list.csv
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,6 @@ bitbake,Bitbake issue handling,,,,x,x,,,,,,,,,,,,,x,,,x,x
cbmc,C Bounded Model Checker,https://github.com/diffblue/cbmc/,,x,,x,x,,,,,,,,,,,,,,,x,
checkbashisms,Shell script linter,https://manpages.debian.org/jessie/devscripts/checkbashisms.1.en.html,,,x,x,,,,x,,,,,,,,,,,,x,x
checksec,check on security issues,https://github.com/slimm609/checksec.sh,,,x,,,,,,,,,x,,,,,,,x,,
clang,C/C++ linter using LLVM,https://clang.llvm.org/extra/clang-tidy/,"meta-clang, manual enable",,,,x,x,x,,,,,,,,,,,,,,x
cmake,Cmake compiler issues,,,,,x,x,x,,,,,,,,,,,,,,x,
configcheck,Check application configurations,,,,x,,,,,,,,,,,,,,,x,,x,
cppcheck,C/C++ linter,https://github.com/danmar/cppcheck,,,,x,x,x,,,,,,,,,,,,,x,x,x
Expand Down
Empty file.

This file was deleted.

This file was deleted.

15 changes: 0 additions & 15 deletions recipes-sca/clang-sca-native/clang-sca-native_1.0.bb

This file was deleted.

30 changes: 0 additions & 30 deletions recipes-sca/clang-sca-native/files/clang.sca.description

This file was deleted.

1 change: 0 additions & 1 deletion test/lang_metaclang.txt
Original file line number Diff line number Diff line change
@@ -1 +0,0 @@
clang

0 comments on commit be4cca8

Please sign in to comment.