Skip to content

Commit

Permalink
build wiringX from source code
Browse files Browse the repository at this point in the history
  • Loading branch information
carbonfix committed May 28, 2024
1 parent 0ed4d9c commit 34fb84e
Show file tree
Hide file tree
Showing 11 changed files with 48 additions and 0 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -253,6 +253,7 @@ BR2_PACKAGE_DUO_PINMUX=y
# BR2_PACKAGE_DUO_PINMUX_DUO is not set
BR2_PACKAGE_DUO_PINMUX_DUO256M=y
# BR2_PACKAGE_DUO_PINMUX_DUOS is not set
BR2_PACKAGE_DUO_WIRINGX=y
BR2_PACKAGE_SKELETON=y
BR2_PACKAGE_HAS_SKELETON=y
BR2_PACKAGE_PROVIDES_SKELETON="skeleton-init-sysv"
Expand Down
1 change: 1 addition & 0 deletions buildroot-2021.05/configs/milkv-duo_musl_riscv64_defconfig
Original file line number Diff line number Diff line change
Expand Up @@ -275,6 +275,7 @@ BR2_PACKAGE_DUO_PINMUX=y
BR2_PACKAGE_DUO_PINMUX_DUO=y
# BR2_PACKAGE_DUO_PINMUX_DUO256M is not set
# BR2_PACKAGE_DUO_PINMUX_DUOS is not set
BR2_PACKAGE_DUO_WIRINGX=y
BR2_PACKAGE_SKELETON=y
BR2_PACKAGE_HAS_SKELETON=y
BR2_PACKAGE_PROVIDES_SKELETON="skeleton-init-sysv"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -253,6 +253,7 @@ BR2_PACKAGE_DUO_PINMUX=y
# BR2_PACKAGE_DUO_PINMUX_DUO is not set
# BR2_PACKAGE_DUO_PINMUX_DUO256M is not set
BR2_PACKAGE_DUO_PINMUX_DUOS=y
BR2_PACKAGE_DUO_WIRINGX=y
BR2_PACKAGE_SKELETON=y
BR2_PACKAGE_HAS_SKELETON=y
BR2_PACKAGE_PROVIDES_SKELETON="skeleton-init-sysv"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -253,6 +253,7 @@ BR2_PACKAGE_DUO_PINMUX=y
# BR2_PACKAGE_DUO_PINMUX_DUO is not set
# BR2_PACKAGE_DUO_PINMUX_DUO256M is not set
BR2_PACKAGE_DUO_PINMUX_DUOS=y
BR2_PACKAGE_DUO_WIRINGX=y
BR2_PACKAGE_SKELETON=y
BR2_PACKAGE_HAS_SKELETON=y
BR2_PACKAGE_PROVIDES_SKELETON="skeleton-init-sysv"
Expand Down
Empty file.
Binary file not shown.
1 change: 1 addition & 0 deletions buildroot-2021.05/package/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@ menu "Target packages"
source "package/busybox/Config.in"
source "package/cvi-pinmux/Config.in"
source "package/duo-pinmux/Config.in"
source "package/duo-wiringx/Config.in"
source "package/skeleton/Config.in"
source "package/skeleton-custom/Config.in"
source "package/skeleton-init-common/Config.in"
Expand Down
26 changes: 26 additions & 0 deletions buildroot-2021.05/package/duo-wiringx/0001-fix-time_t.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From 027658db506ccc0097ad9c1d2cd4f7c9d8210edb Mon Sep 17 00:00:00 2001
From: carbon <[email protected]>
Date: Wed, 17 Apr 2024 15:09:26 +0800
Subject: [PATCH] fix time_t

---
src/wiringx.c | 3 +++
1 file changed, 3 insertions(+)

diff --git a/src/wiringx.c b/src/wiringx.c
index 034674a..4171a75 100644
--- a/src/wiringx.c
+++ b/src/wiringx.c
@@ -113,6 +113,9 @@ static struct spi_t spi[2] = {
} while(0)
#endif

+typedef time_t __time_t;
+typedef suseconds_t __suseconds_t;
+
/* Both the delayMicroseconds and the delayMicrosecondsHard
are taken from wiringPi */
static void delayMicrosecondsHard(unsigned int howLong) {
--
2.25.1

6 changes: 6 additions & 0 deletions buildroot-2021.05/package/duo-wiringx/Config.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
config BR2_PACKAGE_DUO_WIRINGX
bool "wiringX"
help
wiringX for Milk-V Duo

https://github.com/milkv-duo/duo-wiringx
4 changes: 4 additions & 0 deletions buildroot-2021.05/package/duo-wiringx/duo-wiringx.hash
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
# From https://github.com/milkv-duo/duo-wiringx
sha256 3309970f0e6d69f27e6a35ae006ccb12939c25dd223391aa24db450b08978068 duo-wiringx-1.0.1.tar.gz
# Locally calculated
sha256 fab3dd6bdab226f1c08630b1dd917e11fcb4ec5e1e020e2c16f83a0a13863e85 LICENSE
7 changes: 7 additions & 0 deletions buildroot-2021.05/package/duo-wiringx/duo-wiringx.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
DUO_WIRINGX_VERSION = 1.0.1
DUO_WIRINGX_SITE = $(call github,milkv-duo,duo-wiringx,$(DUO_WIRINGX_VERSION))
DUO_WIRINGX_LICENSE = MPL-2.0
DUO_WIRINGX_LICENSE_FILES = COPYING
DUO_WIRINGX_INSTALL_STAGING = YES

$(eval $(cmake-package))

0 comments on commit 34fb84e

Please sign in to comment.