Skip to content

Commit

Permalink
app-admin/winbox: new package, add 4.0_beta6
Browse files Browse the repository at this point in the history
Signed-off-by: jinqiang zhang <[email protected]>
  • Loading branch information
peeweep committed Sep 13, 2024
1 parent b6de60c commit fb4a26d
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/winbox/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST winbox-4.0_beta6.zip 22220141 BLAKE2B bab0170495119541e05ae2def4e82a55896cb3163c8126e3ea3f997e9276139e8af8478cf88bc2f0c3d7cd7228388ef0dd75f09f9bc0b695fe43be89e5baf33b SHA512 2b4e5e4a6d832be1511f39bcb2c01b7096af56c55b496a668cffff13761fee430deab657a5ce9e169b767c1fda22a26ae232dddc207169f73ea581995f62b55f
42 changes: 42 additions & 0 deletions app-admin/winbox/winbox-4.0_beta6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit desktop wrapper

DESCRIPTION="Standalone client for Mikrotik routers"
HOMEPAGE="https://mikrotik.com/"
MY_PN="WinBox"
SRC_URI="https://download.mikrotik.com/routeros/${PN}/${PV//_}/${MY_PN}_Linux.zip -> ${P}.zip"

S="${WORKDIR}"

LICENSE="MikroTik-EULA"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="
media-libs/fontconfig
media-libs/freetype
media-libs/libglvnd
sys-libs/zlib
x11-libs/libxcb
x11-libs/libxkbcommon
x11-libs/xcb-util-image
x11-libs/xcb-util-keysyms
x11-libs/xcb-util-renderutil
x11-libs/xcb-util-wm
"
DEPEND="app-arch/unzip"

src_install() {
# TODO: bundle old libxcb as it doesn't work with current
local instdir="/opt/${PN}"
insinto "${instdir}"
doins -r assets
exeinto "${instdir}"
doexe "${MY_PN}"
make_wrapper "${PN}" "./${MY_PN}" "${instdir}"
make_desktop_entry "${PN}" "${MY_PN}" "${PN}" # "/opt/${PN}/lib"
}

0 comments on commit fb4a26d

Please sign in to comment.