-
Notifications
You must be signed in to change notification settings - Fork 206
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
spirv-llvm-translator-llvm17: New recipe variant to build with CLANG 17
Signed-off-by: Zoltán Böszörményi <[email protected]>
- Loading branch information
Showing
1 changed file
with
41 additions
and
0 deletions.
There are no files selected for viewing
41 changes: 41 additions & 0 deletions
41
recipes-devtools/spirv-llvm-translator/spirv-llvm-translator-llvm17_git.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,41 @@ | ||
LICENSE = "NCSA" | ||
LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=47e311aa9caedd1b3abf098bd7814d1d" | ||
|
||
BRANCH = "llvm_release_170" | ||
SRC_URI = "git://github.com/KhronosGroup/SPIRV-LLVM-Translator;protocol=https;branch=${BRANCH} \ | ||
git://github.com/KhronosGroup/SPIRV-Headers;protocol=https;destsuffix=git/SPIRV-Headers;name=headers;branch=main \ | ||
" | ||
|
||
PV = "17.0.0+git${SRCPV}" | ||
SRCREV = "854179a7451d04bd7fcde0ac200271482bfa8cd2" | ||
SRCREV_headers = "d790ced752b5bfc06b6988baadef6eb2d16bdf96" | ||
|
||
SRCREV_FORMAT = "default_headers" | ||
|
||
S = "${WORKDIR}/git" | ||
|
||
DEPENDS = "spirv-tools clang17" | ||
|
||
inherit cmake pkgconfig python3native | ||
|
||
# Specify any options you want to pass to cmake using EXTRA_OECMAKE: | ||
# for CMAKE_SHARED_LIBS=OFF see https://github.com/KhronosGroup/SPIRV-LLVM-Translator/issues/1868 | ||
EXTRA_OECMAKE = "\ | ||
-DBASE_LLVM_VERSION=${LLVM17VERSION} \ | ||
-DBUILD_SHARED_LIBS=OFF \ | ||
-DCMAKE_BUILD_TYPE=Release \ | ||
-DCMAKE_POSITION_INDEPENDENT_CODE=ON \ | ||
-DCMAKE_SKIP_RPATH=ON \ | ||
-DLLVM_EXTERNAL_LIT=lit \ | ||
-DLLVM_INCLUDE_TESTS=ON \ | ||
-Wno-dev \ | ||
-DCCACHE_ALLOWED=FALSE \ | ||
-DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR=${S}/SPIRV-Headers \ | ||
" | ||
|
||
PACKAGES =+ "${PN}-bin" | ||
FILES:${PN}-bin = "${bindir}/*" | ||
|
||
BBCLASSEXTEND = "native nativesdk" | ||
|
||
EXCLUDE_FROM_WORLD = "1" |