Skip to content

Commit

Permalink
gnu: python-pyelftools: Update to 0.30 [fixes build].
Browse files Browse the repository at this point in the history
This avoids

    Test file 'test/testfiles_for_readelf/aarch64-relocs-le.o.elf'
    .......................FAIL
    ....for file test/testfiles_for_readelf/aarch64-relocs-le.o.elf
    ....for option "--debug-dump=info"
    ....Output #1 is readelf, Output #2 is pyelftools
    @@ Mismatch on line #1:
    >>  compilation unit @ offset 0:<<
    >>  compilation unit @ offset 0x0:<<
     ([('equal', 0, 29, 0, 29), ('insert', 29, 29, 29, 31), ('equal', 29, 30, 31, 32)])

* gnu/packages/python-xyz.scm (python-pyelftools): Update to 0.30.
[description]: Remove gratuitous whitespace.

Change-Id: I6e15e4532affd7faa7272d42adb65a2efcccce46
  • Loading branch information
janneke authored and Christopher Baines committed Jun 29, 2024
1 parent f8d4fd1 commit 9c4b4b9
Showing 1 changed file with 6 additions and 6 deletions.
12 changes: 6 additions & 6 deletions gnu/packages/python-xyz.scm
Original file line number Diff line number Diff line change
Expand Up @@ -144,7 +144,7 @@
;;; Copyright © 2023 Parnikkapore <[email protected]>
;;; Copyright © 2023 Foundation Devices, Inc. <[email protected]>
;;; Copyright © c4droid <[email protected]>
;;; Copyright © 2023 Janneke Nieuwenhuizen <[email protected]>
;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <[email protected]>
;;; Copyright © 2023 Attila Lendvai <[email protected]>
;;; Copyright © 2023, 2024 Troy Figiel <[email protected]>
;;; Copyright © 2024 Timothee Mathieu <[email protected]>
Expand Down Expand Up @@ -23017,7 +23017,7 @@ OpenSSH Server for example.")
(define-public python-pyelftools
(package
(name "python-pyelftools")
(version "0.29")
(version "0.30")
(home-page "https://github.com/eliben/pyelftools")
(source
(origin
Expand All @@ -23026,7 +23026,7 @@ OpenSSH Server for example.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "1mi7i9zlhkkap4q50ciak57ia46mj2jzq0713m3dh0x8j05k9xml"))
(base32 "0gk47mq5cqv6qz35aydn67wma5m70gv5f9f6pg38zny6vsfavmq3"))
(snippet
;; Delete bundled readelf executable.
'(delete-file "test/external_tools/readelf"))))
Expand All @@ -23043,9 +23043,9 @@ OpenSSH Server for example.")
(synopsis
"Analyze binary and library file information")
(description "This Python library provides interfaces for parsing and
analyzing two binary and library file formats ; the Executable and Linking
Format (ELF), and debugging information in the Debugging With Attributed
Record Format (DWARF).")
analyzing two binary and library file formats ; the Executable and Linking
Format (ELF), and debugging information in the Debugging With Attributed
Record Format (DWARF).")
(license license:public-domain)))

(define-public python-pefile
Expand Down

0 comments on commit 9c4b4b9

Please sign in to comment.