Skip to content

Commit

Permalink
bsp: linux-lmp-fscl-imx: add Freescale kernel 6.6-1.0.x-imx
Browse files Browse the repository at this point in the history
Add a recipe for a Linux kernel version by Freescale community based
on NXP tag lf-6.6.3-1.0.0 and stable kernel 6.6.28.

Signed-off-by: Oleksandr Suvorov <[email protected]>
  • Loading branch information
MrCry0 committed May 16, 2024
1 parent 7aa0f46 commit 5663d1a
Show file tree
Hide file tree
Showing 6 changed files with 240 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
From e8bbbc4f7064c794ac28597d4c6227265f6ab47c Mon Sep 17 00:00:00 2001
From: Vanessa Maegima <[email protected]>
Date: Tue, 29 Mar 2022 15:44:59 -0300
Subject: [PATCH] [FIO internal] arch: arm64: dts: imx8mp: enable I2C5 bus

Enable I2C5 bus to connect SE050. I2C5 shares pins with flexcan1, so
disable the latter.

Upstream-Status: Inappropriate [lmp specific]

Signed-off-by: Vanessa Maegima <[email protected]>
Signed-off-by: Oleksandr Suvorov <[email protected]>
---

arch/arm64/boot/dts/freescale/imx8mp-evk.dts | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/arch/arm64/boot/dts/freescale/imx8mp-evk.dts b/arch/arm64/boot/dts/freescale/imx8mp-evk.dts
index 966be019c433b..a14bbd2f163b3 100644
--- a/arch/arm64/boot/dts/freescale/imx8mp-evk.dts
+++ b/arch/arm64/boot/dts/freescale/imx8mp-evk.dts
@@ -416,7 +416,7 @@ &flexcan1 {
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_flexcan1>;
xceiver-supply = <&reg_can1_stby>;
- status = "okay";
+ status = "disabled";
};

&flexcan2 {
@@ -708,7 +708,8 @@ &i2c5 {
clock-frequency = <100000>; /* Lower clock speed for external bus. */
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_i2c5>;
- status = "disabled"; /* can1 pins conflict with i2c5 */
+ pinctrl-assert-gpios = <&pca6416 2 GPIO_ACTIVE_HIGH>; /* set high to select i2c5 instead of flexcan1 */
+ status = "okay";

/* GPIO 2 of PCA6416 is used to switch between CAN1 and I2C5 functions:
* LOW: CAN1 (default, pull-down)
--
2.45.0

Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
From 6dfae3007148e9d488c071aed289604f24675299 Mon Sep 17 00:00:00 2001
From: Michael Scott <[email protected]>
Date: Thu, 4 Aug 2022 17:46:13 -0700
Subject: [PATCH] [FIO internal] arm64: dts: imx8mn-evk.dtsi: re-add bluetooth
reset configuration

This fixes the Murata 1MW bluetooth initialization.

Upstream-Status: Inappropriate [lmp specific]

Signed-off-by: Michael Scott <[email protected]>
Signed-off-by: Ricardo Salveti <[email protected]>
Signed-off-by: Oleksandr Suvorov <[email protected]>
---

arch/arm64/boot/dts/freescale/imx8mn-evk.dtsi | 25 +++++++++++++++++++
1 file changed, 25 insertions(+)

diff --git a/arch/arm64/boot/dts/freescale/imx8mn-evk.dtsi b/arch/arm64/boot/dts/freescale/imx8mn-evk.dtsi
index c63f8f13b73ba..5fc4705c9a50b 100644
--- a/arch/arm64/boot/dts/freescale/imx8mn-evk.dtsi
+++ b/arch/arm64/boot/dts/freescale/imx8mn-evk.dtsi
@@ -59,6 +59,14 @@ reg_usdhc2_vmmc: regulator-usdhc2 {
enable-active-high;
};

+ modem_reset: modem-reset {
+ compatible = "gpio-reset";
+ reset-gpios = <&gpio2 6 GPIO_ACTIVE_LOW>;
+ reset-delay-us = <2000>;
+ reset-post-delay-ms = <40>;
+ #reset-cells = <0>;
+ };
+
ir-receiver {
compatible = "gpio-ir-receiver";
gpios = <&gpio1 13 GPIO_ACTIVE_LOW>;
@@ -492,6 +500,7 @@ &uart1 { /* BT */
assigned-clocks = <&clk IMX8MN_CLK_UART1>;
assigned-clock-parents = <&clk IMX8MN_SYS_PLL1_80M>;
uart-has-rtscts;
+ resets = <&modem_reset>;
status = "okay";

bluetooth {
@@ -518,6 +527,21 @@ &usbphynop1 {
wakeup-source;
};

+&usdhc1 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ pinctrl-names = "default", "state_100mhz", "state_200mhz";
+ pinctrl-0 = <&pinctrl_usdhc1>, <&pinctrl_wlan>;
+ pinctrl-1 = <&pinctrl_usdhc1_100mhz>, <&pinctrl_wlan>;
+ pinctrl-2 = <&pinctrl_usdhc1_200mhz>, <&pinctrl_wlan>;
+ bus-width = <4>;
+ pm-ignore-notify;
+ keep-power-in-suspend;
+ non-removable;
+ cap-power-off-card;
+ wakeup-source;
+};
+
&usbotg1 {
dr_mode = "otg";
hnp-disable;
@@ -778,6 +802,7 @@ MX8MN_IOMUXC_UART1_RXD_UART1_DCE_RX 0x140
MX8MN_IOMUXC_UART1_TXD_UART1_DCE_TX 0x140
MX8MN_IOMUXC_UART3_RXD_UART1_DCE_CTS_B 0x140
MX8MN_IOMUXC_UART3_TXD_UART1_DCE_RTS_B 0x140
+ MX8MN_IOMUXC_SD1_DATA4_GPIO2_IO6 0x19
>;
};

--
2.45.0

Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
From 00bdc23848a76b2cf15cbfe382e26dd24543e0c9 Mon Sep 17 00:00:00 2001
From: Oleksandr Suvorov <[email protected]>
Date: Tue, 30 May 2023 18:04:50 +0300
Subject: [PATCH 2/4] [FIO toup] media: Kconfig: fix double VIDEO_DEV

The VIDEO_IMX_MEDIA dependency of VIDEO_DEV has 2 entries.
Remove a duplicate.

Upstream-Status: Pending

Fixes: commit 9958d30f38b96 ("media: Kconfig: cleanup VIDEO_DEV dependencies")
Signed-off-by: Oleksandr Suvorov <[email protected]>
Signed-off-by: Oleksandr Suvorov <[email protected]>
---

drivers/staging/media/imx/Kconfig | 1 -
1 file changed, 1 deletion(-)

diff --git a/drivers/staging/media/imx/Kconfig b/drivers/staging/media/imx/Kconfig
index 4d67f6a017359..1d28658be8563 100644
--- a/drivers/staging/media/imx/Kconfig
+++ b/drivers/staging/media/imx/Kconfig
@@ -4,7 +4,6 @@ config VIDEO_IMX_MEDIA
depends on ARCH_MXC || COMPILE_TEST
depends on HAS_DMA
depends on VIDEO_DEV
- depends on VIDEO_DEV
depends on IMX_IPUV3_CORE
select MEDIA_CONTROLLER
select V4L2_FWNODE
--
2.45.0

Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
From 28165fc5f96fe871b76a9d9a4d1e89c786253b43 Mon Sep 17 00:00:00 2001
From: Oleksandr Suvorov <[email protected]>
Date: Sat, 3 Jun 2023 20:11:26 +0300
Subject: [PATCH 3/4] [FIO toup] gpu: drm: cadence: select hdmi helper

drm_hdmi_helper driver is required for cdns-hdmi-core driver to be
built well. Select the option DRM_DISPLAY_HDMI_HELPER to fix building
error [1].

[1]
aarch64-none-linux-gnu-ld: drivers/gpu/drm/bridge/cadence/cdns-hdmi-core.o: in function `cdns_hdmi_mode_set':
cdns-hdmi-core.c:(.text+0xfec): undefined reference to `drm_hdmi_avi_infoframe_colorimetry'
aarch64-none-linux-gnu-ld: cdns-hdmi-core.c:(.text+0x10ac): undefined reference to `drm_hdmi_infoframe_set_hdr_metadata'

Upstream-Status: Pending

Signed-off-by: Oleksandr Suvorov <[email protected]>
Signed-off-by: Oleksandr Suvorov <[email protected]>
---

drivers/gpu/drm/bridge/cadence/Kconfig | 1 +
1 file changed, 1 insertion(+)

diff --git a/drivers/gpu/drm/bridge/cadence/Kconfig b/drivers/gpu/drm/bridge/cadence/Kconfig
index f5c5f049b7ca1..7ebbe9ab09db3 100644
--- a/drivers/gpu/drm/bridge/cadence/Kconfig
+++ b/drivers/gpu/drm/bridge/cadence/Kconfig
@@ -63,6 +63,7 @@ config DRM_CDNS_MHDP
config DRM_CDNS_HDMI
tristate "Cadence HDMI DRM driver"
depends on DRM_CDNS_MHDP
+ select DRM_DISPLAY_HDMI_HELPER

config DRM_CDNS_DP
tristate "Cadence DP DRM driver"
--
2.45.0

Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
From be2d7ba742bd21eef917257827096cabe31df593 Mon Sep 17 00:00:00 2001
From: Jorge Ramirez-Ortiz <[email protected]>
Date: Fri, 17 Jul 2020 09:09:37 +0200
Subject: [PATCH 4/4] [FIO toup] hwrng: optee: support generic crypto

Upstream-Status: Pending
Signed-off-by: Jorge Ramirez-Ortiz <[email protected]>
Signed-off-by: Ricardo Salveti <[email protected]>
Signed-off-by: Oleksandr Suvorov <[email protected]>
---

drivers/char/hw_random/optee-rng.c | 2 ++
1 file changed, 2 insertions(+)

diff --git a/drivers/char/hw_random/optee-rng.c b/drivers/char/hw_random/optee-rng.c
index 96b5d546d136a..23d0b55dea862 100644
--- a/drivers/char/hw_random/optee-rng.c
+++ b/drivers/char/hw_random/optee-rng.c
@@ -272,6 +272,8 @@ static int optee_rng_remove(struct device *dev)
static const struct tee_client_device_id optee_rng_id_table[] = {
{UUID_INIT(0xab7a617c, 0xb8e7, 0x4d8f,
0x83, 0x01, 0xd0, 0x9b, 0x61, 0x03, 0x6b, 0x64)},
+ {UUID_INIT(0x035a4479, 0xc369, 0x47f4,
+ 0x94, 0x51, 0xc6, 0xfd, 0xff, 0x28, 0xad, 0x65)},
{}
};

--
2.45.0

18 changes: 18 additions & 0 deletions meta-lmp-bsp/recipes-kernel/linux/linux-lmp-fslc-imx_6.6.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
# We need to extend files paths because the -rt version of this
# recipe includes this one and we need to have patches for this
# recipe available in -rt recipe.
# Extend files paths with the short kernel version to be able to keep
# different patches with the same names for different kernel versions.
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${KSHORT_VER}:${THISDIR}/${PN}:"

include recipes-kernel/linux/linux-lmp-fslc-imx.inc

include recipes-kernel/linux/kmeta-linux-lmp-6.6.y.inc

# Use Freescale kernel by default
LINUX_VERSION ?= "6.6.28"
KERNEL_BRANCH ?= "6.6-1.0.x-imx"

SRCREV_machine = "776652a165f5bbf30c68a5f6213d75b02e8df11c"

DEFAULT_PREFERENCE = "-1"

0 comments on commit 5663d1a

Please sign in to comment.