Skip to content

Commit

Permalink
Add lingmo-calculator
Browse files Browse the repository at this point in the history
  • Loading branch information
chun-awa committed Sep 21, 2024
1 parent 166d251 commit dbfac3b
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
15 changes: 15 additions & 0 deletions lingmo-calculator/.SRCINFO
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
pkgbase = lingmo-calculator
pkgdesc = A simple calculator.
pkgver = 0.6.1
pkgrel = 1
url = https://lingmo.org
arch = x86_64
license = GPL
makedepends = cmake
makedepends = extra-cmake-modules
depends = qt5-tools
depends = qt5-quickcontrols2
source = https://github.com/LingmoOS/lingmo-calculator/archive/refs/tags/0.6.1.tar.gz
sha256sums = e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855

pkgname = lingmo-calculator
31 changes: 31 additions & 0 deletions lingmo-calculator/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Maintainer: chun-awa <[email protected]>
# Maintainer: Intro <[email protected]>
pkgname=lingmo-calculator
arch=("x86_64")
depends=(
"qt5-tools"
"qt5-quickcontrols2"
)
makedepends=("cmake" "extra-cmake-modules")
pkgdesc="A simple calculator."
pkgrel=1
pkgver=0.6.1
url="https://lingmo.org"
license=("GPL")
source=("https://github.com/LingmoOS/${pkgname}/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855')

prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
mkdir -p build
}

build() {
cd "$srcdir/${pkgname}-${pkgver}/build"
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
cd $pkgname-$pkgver/build
make DESTDIR="$pkgdir" install
}

0 comments on commit dbfac3b

Please sign in to comment.