Skip to content

Commit

Permalink
recipes-bsp: u-boot: add u-boot-qcom recipe
Browse files Browse the repository at this point in the history
Add u-boot-qcom recipe. This fetch from Linaro repo and build the
u-boot-qcs6490-rb3gen2.mbn ready to be flashed into rb3gen2 board
usind fastboot:

fastboot flash uefi_a ./u-boot-qcs6490-rb3gen2.mbn

Some logs:

U-Boot 2024.10-rc4-00620-ga61af132fb90 (Sep 09 2024 - 10:00:06 +0000)

Model: Qualcomm Technologies, Inc. Robotics RB3gen2
DRAM:  6 GiB (effective 5.9 GiB)
serial_msm_geni serial@994000: pinctrl_select_state_full: uclass_get_device_by_phandle_id: err=-19
serial_msm_geni serial@994000: pinctrl_select_state_full: uclass_get_device_by_phandle_id: err=-19
Core:  57 devices, 28 uclasses, devicetree: board

Loading Environment from nowhere... OK
In:    serial,button-kbd
Out:   serial,vidconsole
Err:   serial,vidconsole
qcom-ufshcd ufs@1d84000: Qcom UFS HC version: 4.3.0
qcom-ufshcd ufs@1d84000: [RX, TX]: gear=[3, 3], lane[2, 2], pwr[FAST MODE, FAST MODE], rate = 2
QCOM-FMP: Failed to find boot partition
Net:   No ethernet found.

scanning bus for devices...
  Device 0: (0:0) Vendor: SAMSUNG Prod.: KM2L9001CM-B518 Rev: 0700
            Type: Hard Disk
            Capacity: 118871.9 MB = 116.0 GB (30431231 x 4096)
  Device 1: (0:1) Vendor: SAMSUNG Prod.: KM2L9001CM-B518 Rev: 0700
            Type: Hard Disk
            Capacity: 7.9 MB = 0.0 GB (2047 x 4096)
  Device 2: (0:2) Vendor: SAMSUNG Prod.: KM2L9001CM-B518 Rev: 0700
            Type: Hard Disk
            Capacity: 7.9 MB = 0.0 GB (2047 x 4096)
  Device 3: (0:3) Vendor: SAMSUNG Prod.: KM2L9001CM-B518 Rev: 0700
            Type: Hard Disk
            Capacity: 31.9 MB = 0.0 GB (8191 x 4096)
  Device 4: (0:4) Vendor: SAMSUNG Prod.: KM2L9001CM-B518 Rev: 0700
            Type: Hard Disk
            Capacity: 3071.9 MB = 2.9 GB (786431 x 4096)
  Device 5: (0:5) Vendor: SAMSUNG Prod.: KM2L9001CM-B518 Rev: 0700
            Type: Hard Disk
            Capacity: 31.9 MB = 0.0 GB (8191 x 4096)
starting USB...
Bus usb@a600000: Register 2000340 NbrPorts 2
Starting the controller
USB XHCI 1.10
scanning bus usb@a600000 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Hit any key to stop autoboot:  0
=> <INTERRUPT>

Signed-off-by: Tommaso Merciai <[email protected]>
  • Loading branch information
Scott31393 committed Sep 19, 2024
1 parent c4c8040 commit e25601e
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
12 changes: 12 additions & 0 deletions recipes-bsp/u-boot/u-boot-qcom-common_2024.10.inc
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"

DEPENDS += "flex-native bison-native"

SRC_URI = "git://git.codelinaro.org/linaro/qcomlt/u-boot.git;branch=${SRCBRANCH};protocol=https"

SRCREV = "bea334ce7578d4cb645cf22d423ec11271feecfe"
SRCBRANCH = "caleb/rbx-integration"

S = "${WORKDIR}/git"
B = "${WORKDIR}/build"
37 changes: 37 additions & 0 deletions recipes-bsp/u-boot/u-boot-qcom_git.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
SUMMARY = "U-Boot bootloader with support for Qualcom Computer on Modules"
HOMEPAGE = "https://git.codelinaro.org/linaro/qcomlt/u-boot"
SECTION = "bootloaders"

DESCRIPTION = "U-Boot based on mainline U-Boot used by Qualcomm BSP in \
order to provide support for some backported features and fixes, or because it \
was submitted for revision and it takes some time to become part of a stable \
version, or because it is not applicable for upstreaming."

BASEPV = "2024.10"
PV = "${BASEPV}+git${SRCPV}"

require recipes-bsp/u-boot/u-boot.inc
require u-boot-qcom-common_${BASEPV}.inc

DEPENDS += " \
xxd-native \
dtc-native \
qtestsign-native\
"

PROVIDES += "u-boot"

B = "${WORKDIR}/build"

PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_MACHINE = "(qcom-armv8a)"

do_compile:append() {
export CRYPTOGRAPHY_OPENSSL_NO_LEGACY=1
qtestsign -v6 hyp -o ${B}/qcm6490_defconfig/u-boot.mbn ${B}/qcm6490_defconfig/u-boot.elf
}

do_deploy:append() {
cp -r ${B}/qcm6490_defconfig/u-boot.mbn ${DEPLOY_DIR_IMAGE}/u-boot-qcs6490-rb3gen2.mbn
cp -r ${B}/qcm6490_defconfig/u-boot.elf ${DEPLOY_DIR_IMAGE}/u-boot-qcs6490-rb3gen2.elf
}

0 comments on commit e25601e

Please sign in to comment.